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Basics of PDF 
Accessibility

Melanie Thornton
Digital Accessibility Consultant

Director, Initiatives for Advancing Disability Access
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Housekeeping
• Recording
• Captioning
• Handouts
• Q and A
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Handouts

exploreaccess.org/handouts/
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https://exploreaccess.org/handouts/
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Alternative Ways of Navigating
• Screen readers: 

Voiceover, JAWS/Fusion, NVDA
• Magnification Software
• Braille display
• Voice recognition software
• Keyboard only navigation
• Other mouse alternatives
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Why PDF?
• PDF stands for Portable Document Format
• Often used to maintain specific look of a 

document
• Advantage: Will open across several 

devices and platforms 👍
• Disadvantage: If not designed with access 

in mind, can be completely inaccessible to 
screen reader users 👎

5

What Makes a PDF Accessible? (1 of 2)

• PDFs must meet the same accessibility 
standards as other documents:
• Good contrast 
• Clear, readable fonts of at least 12-

point size
• Proper heading structure
• Meaningful link text
• Alt text for images. 
• Well-structured tables

6
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What Makes a PDF Accessible? (2 of 2)

• Tagging layer:
• Screen readers rely on the tag layer to 

interpret the document’s structure and 
content. 
• Ensuring PDFs are generated correctly 

from the source will help ensure they 
are tagged.
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Common Barriers: PDF
• No tags
• Images missing alt text
• Missing heading structure
• Incorrect reading order
• Some content missing tags
• Improperly tagged tables
• Scanned PDFs that are an image of text
• PDF forms without correct labeling
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Screen Reader User Experience

How a Screen Reader Works: Reading a Document(YouTube)
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https://youtu.be/M4Z7oKJ2AUA?si=pWKppkDRJZyiDO1k&t=66
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Creating an Accessible PDF from Source Document – 
Microsoft Word and PowerPoint
• Follow best practices for accessibility in creating 

the original document
• Be sure to Save as PDF rather than Print to PDF.
• On a Mac, select the radio button that is 

labeled “Best for electronic distribution and 
accessibility”

• If you have Acrobat Pro DC, use the Create PDF 
Add-On.
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Creating an Accessible PDF from Source 
Document – Other  Applications

• Adobe InDesign can also be used to create an accessible PDF.
• Google Docs: File downloaded as a PDF is accessible
• Google Slides: Exports are untagged and therefore inaccessible.
• Other applications: Exporting to PDF will have mixed results.
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Accessible Source 
Document: MS Word
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Using Headings to Provide Structure

•Headings provide structure to your document.
•Using normal text and applying styles such as 
larger size, different color, or bolder text does not 
create a true heading.
•Don’t use headings when you don’t need a true 
heading.
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How to Add Headings
• Highlight the text
• Click on the appropriate 

heading
• Or use keyboard shortcuts
• PC: Control+Alt+1
• Mac: Command+Option+1
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Modify Headings
• Modify a heading by:
• Right clicking on the 

heading in the styles group 
and choosing modify OR
• Change the heading 

in your document and 
choosing Update 
Heading to Match 
Selection

15
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Alternative Text:

a text description of an image 
(or other non-text content)
Also called: 
alt text, image description
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Why Use Alt Text

• Without alt text, a screen 
reader user will not know 
what an image is. 
• Images often convey 

important information.
• The screen reader will 

just say “graphic”
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A Pomeranian 
wearing glasses looks 

down at an open 
book.

Sample Alt Text

18
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How to Add Alt Text (1)

•Right click on the image
•Choose View Alt Text
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How to Add Alt Text (2)

•Write the description in the box 
that appears to the right of the 
document.
•Describe what is in the image.
•No need to say “image of” or 
“picture of”
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Purely Decorative Image

• Images that do not add 
anything to the content
• Images that are redundant 

to the content
• Images that are visual 

separators 

21
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Other Elements 
• Link names should be meaningful out of context.
• Lists should use bulleted list tools within MS Word.
• Tables should have designated header rows
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Using the Accessibility 
Checker (1 of 2)
• Select Review Ribbon
• Select Accessibility 

Checker
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Using the Accessibility 
Checker (2 of 2)
• Panel opens to the right
• Identifies accessibility 

issues

24
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Save as PDF

• Always “Save As” PDF instead of 
Printing to PDF
• Newer versions: Save a Copy 

and then choose PDF from 
dropdown menu

• If using a Mac, also choose “Best 
for electronic distribution and 
accessibility”
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Demo: MS Word to PDF
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Existing PDFs
How Do I Know It It Is Accessible

27
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Is the PDF Accessible?

• Is there actual text?
• Is the PDF tagged?
• Are there accessibility errors?
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Demo: 
Checking Existing PDFs
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Free Accessibility Checkers

• PDF Accessibility Checker (Windows)
• AxesCheck

30

https://pac.pdf-accessibility.org/en
https://pac.pdf-accessibility.org/en
https://check.axes4.com/en/
https://check.axes4.com/en/
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Fixing Inaccessible PDFs

31

Got Source Document?

•Fix issues in the source document
•Resave to PDF
•Recheck for accessibility
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Problem: PDF is a Scanned Image

Use Optical Character Recognition (OCR) to recognize and 
render text. 

If the scan is a quality one, you may be able to fix the problem using 
Acrobat Pro.
• Windows: Select View > Tools > Recognize Text
• Mac: Select Edit > Scan and OCR > Recognize Text > In File

33
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Problem: PDF is Untagged

Use Adobe Acrobat Pro to auto-generate tags. 
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Auto-Tagging a PDF

• Open tags panel
• Right click on No tags 

available
• Choose Autotag document
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Problem: PDF is Tagged But Has 
Significant Accessibility Issues
Export document to MS Word (or MS PowerPoint). 

• Simple documents may export well to MS Word. 
• More complex documents may be better edited in MS PowerPoint.

36
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Exporting PDF to MS Word

• Choose All Tools
• Then Export a PDF
• Then Microsoft Word (or 

PowerPoint)
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Problem: PDF is Tagged with Minor 
Accessibility Errors

Fix accessibility errors in tag tree or using the 
Reading Order tool in Acrobat Pro.
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Remediating a PDF Using Tag Tree

• Those who are familiar with HTML may 
prefer fixing errors using the Tag Tree. 
• To view the tags panel, select View > 

Show/Hide > Side Panel > Tags.

39
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Remediating a PDF Using Reading 
Order Tool
• To access the Reading Order tool, select 

All Tools > Prepare for Accessibility > Fix reading order.
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Demo: 
Fixing Existing PDFs
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Other PDF Accessibility Remediation Tools
• AccessibilityNow Remediate 

(Crawford Technologies)
• CommonLook PDF (Allyant)
• Equidox PDF Accessibility Software
• Grackle PDF
• PDFix
• PREP Document Remediation Software 

(Continual Engine)

42

https://crawfordtech.com/products/accessibilitynow/
https://crawfordtech.com/products/accessibilitynow/
https://crawfordtech.com/products/accessibilitynow/
https://allyant.com/pdf-accessibility-software-solutions/commonlook-pdf/
https://allyant.com/pdf-accessibility-software-solutions/commonlook-pdf/
https://equidox.co/pdf-solutions/pdf-accessibility-software/
https://equidox.co/pdf-solutions/pdf-accessibility-software/
https://www.grackledocs.com/en/products-services/grackle-pdf/
https://www.grackledocs.com/en/products-services/grackle-pdf/
https://pdfix.net/
https://pdfix.net/
https://www.continualengine.com/prep-pdf-remediation-software/
https://www.continualengine.com/prep-pdf-remediation-software/
https://www.continualengine.com/prep-pdf-remediation-software/
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PDF Accessibility Resources
• Adobe: PDF accessibility
• Deque: 8 Step PDF Accessibility Checklist
• Deque: Quick Reference Guide: Basic PDF Accessibility (PDF)
• Harvard: PDF Accessibility
• University of Arizona: PDF Accessibility
• University of Colorado – Boulder: Understanding PDF Accessibility
• University of Washington: Checking PDFs for Accessibility
• WebAIM: PDF Accessibility
• W3C; PDF Techniques
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Other Digital Accessibility Resources

• Explore Access: Designing an Accessible Online Course
• DOE: OCR Video Series
• WebAIM
• W3C: Web Accessibility Initiative
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Thanks to our funders
• iCAN (Increasing Capabilities Access Network) 

is the Arkansas statewide Assistive Technology 
program designed to make technology 
available and accessible for everyone who 
needs it.

• The Southwest ADA Center is the Southwest's 
leading resource on the Americans with 
Disabilities Act and related disability rights 
laws. The Center is part of the ADA National 
Network.
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https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html
https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html
https://www.deque.com/blog/your-eight-step-pdf-accessibility-checklist/
https://www.deque.com/blog/your-eight-step-pdf-accessibility-checklist/
https://pe.osu.edu/sites/default/files/2024-07/basic-pdf-reference-guide2.pdf
https://pe.osu.edu/sites/default/files/2024-07/basic-pdf-reference-guide2.pdf
https://accessibility.huit.harvard.edu/pdf
https://accessibility.huit.harvard.edu/pdf
https://accessibility.arizona.edu/content/pdf-accessibility
https://accessibility.arizona.edu/content/pdf-accessibility
https://www.colorado.edu/digital-accessibility/pdfs
https://www.colorado.edu/digital-accessibility/pdfs
https://www.colorado.edu/digital-accessibility/pdfs
https://www.colorado.edu/digital-accessibility/pdfs
https://www.washington.edu/accesstech/documents/check-pdfs/
https://www.washington.edu/accesstech/documents/check-pdfs/
https://webaim.org/techniques/acrobat/
https://webaim.org/techniques/acrobat/
https://www.w3.org/WAI/WCAG22/Techniques/
https://www.w3.org/WAI/WCAG22/Techniques/
https://exploreaccess.org/accessible-online-course/
https://exploreaccess.org/accessible-online-course/
https://adata.org/ocr-videos
https://adata.org/ocr-videos
https://webaim.org/
https://webaim.org/
https://www.w3.org/WAI/
https://www.w3.org/WAI/
https://www.w3.org/WAI/
https://www.w3.org/WAI/
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Upcoming Webinars

• Dates to be determined: 
• Universal Design and Instruction
• Accessible Tables and Excel Worksheets
• Accessibility with Canva
• Creating an Accessible Campus

• Visit: uofapartners.uark.edu/news-events
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Contact Me

Melanie Thornton
Digital Access Consultant
University of Arkansas Partners
Email: mthornt@uark.edu 
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https://uofapartners.uark.edu/news-events/
https://uofapartners.uark.edu/news-events/
https://uofapartners.uark.edu/news-events/
mailto:mthornt@uark.edu

